MailCleaner 2017 "Jessie"/"Final" feedback

Give your impressions and feelings about MailCleaner

Moderators: FlorianB, Pascal, bourgeois, mentor

FlorianB
Posts: 258
Joined: Wed Apr 01, 2015 2:27 pm
How did you hear about Mailcleaner: job

Re: MailCleaner 2017 "Jessie"/"Final" feedback

Postby FlorianB » Sun Sep 17, 2017 1:40 pm

Hello,
Only step that could change the password in slave DB about synchronization is the part when you add the slave using slave.pl.
You need to continue to use, password stored in mailcleaner.conf of each machine when asked for password for the cluster.
Hmmmm and you should have launch the Wizard on each of your MailCleaner before that, not only on the master. Passwords for root, DB etc are machine dependant.
Regards,
Florian
snvdberg
Posts: 17
Joined: Tue Jul 21, 2015 5:17 pm
How did you hear about Mailcleaner: Sites

Re: MailCleaner 2017 "Jessie"/"Final" feedback

Postby snvdberg » Sun Sep 17, 2017 8:10 pm

FlorianB wrote:Hello,
Only step that could change the password in slave DB about synchronization is the part when you add the slave using slave.pl.
You need to continue to use, password stored in mailcleaner.conf of each machine when asked for password for the cluster.
Hmmmm and you should have launch the Wizard on each of your MailCleaner before that, not only on the master. Passwords for root, DB etc are machine dependant.
Regards,
Florian


I ran the wizard before adding them to the cluster.
User avatar
ChrisKnight
Posts: 15
Joined: Sat Nov 01, 2014 6:39 pm
How did you hear about Mailcleaner: googling for an anti-spam solution

Re: MailCleaner 2017 "Jessie"/"Final" feedback

Postby ChrisKnight » Sun Sep 17, 2017 11:13 pm

Is it possible to get a VMDK or an OFA built on an older virtual hardware version? I'm running ESXi 5.5, and it would be extremely painful to upgrade right now. When I try to create a new VM and have it attach the .vmdk it simply doesn't show up in the file browser. When I try to import the OVA I get a warning that vmx-12 is not supported. I'm hacking the embedded .ovf file now, and giving that a try, but it would be super sweet if you could just build an instance on v8 and then export to .ovf for those of us stuck on older versions of vmware. :)
User avatar
Martijn
Posts: 38
Joined: Wed Aug 20, 2014 5:31 pm
How did you hear about Mailcleaner: We love to work with Mailcleaner
Location: Enter - Netherlands
Contact:

Re: MailCleaner 2017 "Jessie"/"Final" feedback

Postby Martijn » Sun Sep 17, 2017 11:23 pm

Just open the file with proper tools and change the vmx-12 line to the right value (was it 08?).
Image
User avatar
ChrisKnight
Posts: 15
Joined: Sat Nov 01, 2014 6:39 pm
How did you hear about Mailcleaner: googling for an anti-spam solution

Re: MailCleaner 2017 "Jessie"/"Final" feedback

Postby ChrisKnight » Sun Sep 17, 2017 11:25 pm

Martijn wrote:Just open the file with proper tools and change the vmx-12 line to the right value (was it 08?).


Yeah, I literally said I was doing that in my post: "I'm hacking the embedded .ovf file now"
User avatar
ChrisKnight
Posts: 15
Joined: Sat Nov 01, 2014 6:39 pm
How did you hear about Mailcleaner: googling for an anti-spam solution

Re: MailCleaner 2017 "Jessie"/"Final" feedback

Postby ChrisKnight » Mon Sep 18, 2017 1:47 am

Lag in tracing data?

So, I've got an instance spun up. I used the migration script to move over the seven tables from the mc_config database, and spot checked all the configs. It looked good, so I put it on-line.

If I go to Monitoring/Reporting and I generate a report for all domains, I quickly see that I'm processing mail. One one of my domains, I've received 32 messages; 11 spam and 21 clean. Cool.

So, now I go to Management/Tracking and I select that particular domain from the drop-down. When I hit the Refresh button I get "Message traces found : 0 messages"

Shouldn't I see tracing data for those 32 messages?
User avatar
ChrisKnight
Posts: 15
Joined: Sat Nov 01, 2014 6:39 pm
How did you hear about Mailcleaner: googling for an anti-spam solution

Re: MailCleaner 2017 "Jessie"/"Final" feedback

Postby ChrisKnight » Mon Sep 18, 2017 2:01 am

ChrisKnight wrote:Shouldn't I see tracing data for those 32 messages?


Yup, something is borked with this new install. I dropped my old instance back in place, fired a test message through it, and that test message immediately showed up in message tracing.

Has anyone else had this issue after using the migration script? Has anyone had this issue after a clean install and config?
PKej
Posts: 8
Joined: Tue Dec 08, 2015 9:20 am
How did you hear about Mailcleaner: web magazine

Re: MailCleaner 2017 "Jessie"/"Final" feedback

Postby PKej » Mon Sep 18, 2017 9:00 am

ChrisKnight:

Please take a look at these previous posts, it should resolve your problem.

viewtopic.php?f=4&t=2500#p10596
viewtopic.php?f=4&t=2500#p10604
User avatar
Martijn
Posts: 38
Joined: Wed Aug 20, 2014 5:31 pm
How did you hear about Mailcleaner: We love to work with Mailcleaner
Location: Enter - Netherlands
Contact:

Re: MailCleaner 2017 "Jessie"/"Final" feedback

Postby Martijn » Mon Sep 18, 2017 9:44 am

Some messages are marked as spam and quarantined but don't show up in quarantaine...

Code: Select all

Incoming MTA stage:   2017-09-18 10:03:05 1dtr1F-0002qR-9c DKIM: d=gmail.com s=20161025 c=relaxed/relaxed a=rsa-sha256 b=2048 [verification succeeded]
2017-09-18 10:03:05 1dtr1F-0002qR-9c DMARC results: spf_domain=gmail.com dmarc_domain=gmail.com spf_align=yes dkim_align=yes enforcement='Accept'
2017-09-18 10:03:05 1dtr1F-0002qR-9c <= xxxxxx@gmail.com H=mail-wm0-f52.google.com [74.125.82.52] P=esmtps X=TLSv1.2:ECDHE-RSA-AES128-GCM-SHA256:128 CV=no S=271371 id=59bf7db0c011e_4be874fe7810155b@xxxxxx.mail
2017-09-18 10:03:05 1dtr1F-0002qR-9c => xxxxx@xxxxx.com R=filter_forward T=local_smtp S=275989 H=127.0.0.1 [127.0.0.1] C="250 OK id=1dtr1F-0002qV-EJ"
2017-09-18 10:03:05 1dtr1F-0002qR-9c Completed
Filtering MTA stage:   2017-09-18 10:03:05 1dtr1F-0002qV-EJ <= xxxxx@gmail.com H=(xxxxxxxxx.nl) [127.0.0.1] P=esmtp S=271371 id=59bf7db0c011e_4be874fe7810155b@xxxxx.mail
Filtering Engine:   Sep 18 10:03:05 localhost MailScanner[9600]: <A> tag found in message 1dtr1F-0002qV-EJ from xxxxx@gmail.com
Sep 18 10:03:05 localhost MailScanner[9600]: HTML Img tag found in message 1dtr1F-0002qV-EJ from xxxxx@gmail.com
Sep 18 10:03:06 localhost MailScanner[9600]: Newsl result is not newsletter (1.0/5.0) for 1dtr1F-0002qV-EJ
Sep 18 10:03:08 localhost MailScanner[9600]: NiceBayes result is not spam (50%%) for 1dtr1F-0002qV-EJ
Sep 18 10:03:11 localhost MailScanner[9600]: PreRBLs found sender hostname: mail-wm0-f52.google.com for 74.125.82.52 on message 1dtr1F-0002qV-EJ
Sep 18 10:03:11 localhost MailScanner[9600]: PreRBLs not checking IPRBL on 74.125.82.52 because IP is whitelisted for message 1dtr1F-0002qV-EJ
Sep 18 10:03:29 localhost MailScanner[9600]: Spamc result is spam (5.3/5.0) for 1dtr1F-0002qV-EJ
Sep 18 10:03:29 localhost MailScanner[9600]: Message 1dtr1F-0002qV-EJ from 74.125.82.52 (xxxxx@gmail.com) to xxxxxx.com is spam, Newsl (score=1.0, required=5.0, MC_NEWS_ENWNEWS=1), Spamc (score=5.3, required=5.0, BAYES_99 3.5, BAYES_999 0.2, RCVD_IN_MSPIKE_WL -0.0, RCVD_IN_SORBS_SPAM 0.5, DKIM_VALID -0.1, RCVD_IN_MSPIKE_H3 -0.0, RCVD_IN_DNSWL_NONE -0.0, DKIM_VALID_AU -0.1, MIME_HTML_ONLY 0.7, HTML_MESSAGE 0.0, HTML_FONT_LOW_CONTRAST 0.0, DKIM_SIGNED 0.1, HK_RANDOM_FROM 0.0, KAM_NUMSUBJECT 0.5)
Sep 18 10:03:29 localhost MailScanner[9600]: Profiled SpamCheck for message 1dtr1F-0002qV-EJ: (ClamSpam_Check:2.3976s) (Newsl_Check:0.2562s) (NiceBayes_Check:2.7976s) (PreRBLs_Check:0.0124s) (Prefilters:23.3608s) (SpamCacheCheck:0.0055s) (Spamc_Check:14.1966s) (TrustedSources_Check:0.0952s) (UriRBLs_Check:3.5983s)
Sep 18 10:03:29 localhost MailScanner[9600]: Spam Actions: message 1dtr1F-0002qV-EJ actions are deliver
Sep 18 10:03:29 localhost MailScanner[9600]: Count updated for 1dtr1F-0002qV-EJ
Sep 18 10:03:29 localhost MailScanner[9600]: Count updated in daemon for 1dtr1F-0002qV-EJ
Outgoing stage:   2017-09-18 10:03:29 1dtr1F-0002qV-EJ => xxxx <xxxx@xxxx.com> R=filter_checkspam T=spam_store S=272099
2017-09-18 10:03:29 1dtr1F-0002qV-EJ Completed
Spam handling stage:   2017-09-18 10:03:32 (2) 174484: message 1dtr1F-0002qV-EJ R:<xxxx@xxxx.com> S:<xxxx@gmail.com> score: 1 status: want quarantine


Looks like the quarantine part goes OK but message is not shown in quarantine.
After comparing tracing logs, there are more messages not available in quarantine.

Messages are present in /var/mailcleaner/spam folder ... weird!
Image
DirkV
Posts: 6
Joined: Thu Jun 01, 2017 10:24 am
How did you hear about Mailcleaner: Google

Re: MailCleaner 2017 "Jessie"/"Final" feedback

Postby DirkV » Mon Sep 18, 2017 10:55 am

Martijn wrote:Some messages are marked as spam and quarantined but don't show up in quarantaine...

Code: Select all

Incoming MTA stage:   2017-09-18 10:03:05 1dtr1F-0002qR-9c DKIM: d=gmail.com s=20161025 c=relaxed/relaxed a=rsa-sha256 b=2048 [verification succeeded]
2017-09-18 10:03:05 1dtr1F-0002qR-9c DMARC results: spf_domain=gmail.com dmarc_domain=gmail.com spf_align=yes dkim_align=yes enforcement='Accept'
2017-09-18 10:03:05 1dtr1F-0002qR-9c <= xxxxxx@gmail.com H=mail-wm0-f52.google.com [74.125.82.52] P=esmtps X=TLSv1.2:ECDHE-RSA-AES128-GCM-SHA256:128 CV=no S=271371 id=59bf7db0c011e_4be874fe7810155b@xxxxxx.mail
2017-09-18 10:03:05 1dtr1F-0002qR-9c => xxxxx@xxxxx.com R=filter_forward T=local_smtp S=275989 H=127.0.0.1 [127.0.0.1] C="250 OK id=1dtr1F-0002qV-EJ"
2017-09-18 10:03:05 1dtr1F-0002qR-9c Completed
Filtering MTA stage:   2017-09-18 10:03:05 1dtr1F-0002qV-EJ <= xxxxx@gmail.com H=(xxxxxxxxx.nl) [127.0.0.1] P=esmtp S=271371 id=59bf7db0c011e_4be874fe7810155b@xxxxx.mail
Filtering Engine:   Sep 18 10:03:05 localhost MailScanner[9600]: <A> tag found in message 1dtr1F-0002qV-EJ from xxxxx@gmail.com
Sep 18 10:03:05 localhost MailScanner[9600]: HTML Img tag found in message 1dtr1F-0002qV-EJ from xxxxx@gmail.com
Sep 18 10:03:06 localhost MailScanner[9600]: Newsl result is not newsletter (1.0/5.0) for 1dtr1F-0002qV-EJ
Sep 18 10:03:08 localhost MailScanner[9600]: NiceBayes result is not spam (50%%) for 1dtr1F-0002qV-EJ
Sep 18 10:03:11 localhost MailScanner[9600]: PreRBLs found sender hostname: mail-wm0-f52.google.com for 74.125.82.52 on message 1dtr1F-0002qV-EJ
Sep 18 10:03:11 localhost MailScanner[9600]: PreRBLs not checking IPRBL on 74.125.82.52 because IP is whitelisted for message 1dtr1F-0002qV-EJ
Sep 18 10:03:29 localhost MailScanner[9600]: Spamc result is spam (5.3/5.0) for 1dtr1F-0002qV-EJ
Sep 18 10:03:29 localhost MailScanner[9600]: Message 1dtr1F-0002qV-EJ from 74.125.82.52 (xxxxx@gmail.com) to xxxxxx.com is spam, Newsl (score=1.0, required=5.0, MC_NEWS_ENWNEWS=1), Spamc (score=5.3, required=5.0, BAYES_99 3.5, BAYES_999 0.2, RCVD_IN_MSPIKE_WL -0.0, RCVD_IN_SORBS_SPAM 0.5, DKIM_VALID -0.1, RCVD_IN_MSPIKE_H3 -0.0, RCVD_IN_DNSWL_NONE -0.0, DKIM_VALID_AU -0.1, MIME_HTML_ONLY 0.7, HTML_MESSAGE 0.0, HTML_FONT_LOW_CONTRAST 0.0, DKIM_SIGNED 0.1, HK_RANDOM_FROM 0.0, KAM_NUMSUBJECT 0.5)
Sep 18 10:03:29 localhost MailScanner[9600]: Profiled SpamCheck for message 1dtr1F-0002qV-EJ: (ClamSpam_Check:2.3976s) (Newsl_Check:0.2562s) (NiceBayes_Check:2.7976s) (PreRBLs_Check:0.0124s) (Prefilters:23.3608s) (SpamCacheCheck:0.0055s) (Spamc_Check:14.1966s) (TrustedSources_Check:0.0952s) (UriRBLs_Check:3.5983s)
Sep 18 10:03:29 localhost MailScanner[9600]: Spam Actions: message 1dtr1F-0002qV-EJ actions are deliver
Sep 18 10:03:29 localhost MailScanner[9600]: Count updated for 1dtr1F-0002qV-EJ
Sep 18 10:03:29 localhost MailScanner[9600]: Count updated in daemon for 1dtr1F-0002qV-EJ
Outgoing stage:   2017-09-18 10:03:29 1dtr1F-0002qV-EJ => xxxx <xxxx@xxxx.com> R=filter_checkspam T=spam_store S=272099
2017-09-18 10:03:29 1dtr1F-0002qV-EJ Completed
Spam handling stage:   2017-09-18 10:03:32 (2) 174484: message 1dtr1F-0002qV-EJ R:<xxxx@xxxx.com> S:<xxxx@gmail.com> score: 1 status: want quarantine


Looks like the quarantine part goes OK but message is not shown in quarantine.
After comparing tracing logs, there are more messages not available in quarantine.

Messages are present in /var/mailcleaner/spam folder ... weird!


Seeing this message made me check my logs and I can confirm I have the same issue.
User avatar
Martijn
Posts: 38
Joined: Wed Aug 20, 2014 5:31 pm
How did you hear about Mailcleaner: We love to work with Mailcleaner
Location: Enter - Netherlands
Contact:

Re: MailCleaner 2017 "Jessie"/"Final" feedback

Postby Martijn » Mon Sep 18, 2017 11:14 am

After running a /usr/mailcleaner/bin/resync_db.sh 1 of 3 messages are back in the quarantine view but not all.....
Image
FlorianB
Posts: 258
Joined: Wed Apr 01, 2015 2:27 pm
How did you hear about Mailcleaner: job

Re: MailCleaner 2017 "Jessie"/"Final" feedback

Postby FlorianB » Mon Sep 18, 2017 5:33 pm

Hello,
Could I get an ssh access on one of your MailCleaner (Optionnally: change the root password before giving it to me via private message) to investigate the case ?
I didn't notice this anomaly and there were more than 900 download of this new Final MailCleaner so I suppose this is a specific problem on both your machine (else i hope people would have invade the forum and would have launch object to developpers :lol:).
If messages are not present in spam quarantine but are present in tracing, this means than the slaves (could be the slave instance part of the master) can't connect to the main instance of the DB to indicate the received spam. Two cases:
1) You also used the Patch to mix 201410 and 2017** and it appears than there is a bug in this patch of you should'nt use it in your case.
or
2) There is a problem with passwords between main DB instance and slave instance. Nothing known but should have appears in red during configurator or could be related to initial configurator DB bug but can't happen on a final.
Thank you.
Regards,
Florian
MailCleaner Team
FlorianB
Posts: 258
Joined: Wed Apr 01, 2015 2:27 pm
How did you hear about Mailcleaner: job

Re: MailCleaner 2017 "Jessie"/"Final" feedback

Postby FlorianB » Mon Sep 18, 2017 5:35 pm

snvdberg wrote:Hi,

After using the configuration wizard for changing the passwords apache wouldn't start anymore with the following error:
ERROR 1045 (28000): Access denied for user 'mailcleaner'@'localhost' (using password: YES)

It looks like special characters are not allowed in database password. I reinstalled en ran the configuration wizard again without special characters in the database password and the issue was fixed.


Hello snvdberg,
Thanks for the report, could you specify what character exactly is not allowed. Since the final version, all character should have been escaped correctly with proper functions (including this '!')
Thanks,
Regards,
Florian
FlorianB
Posts: 258
Joined: Wed Apr 01, 2015 2:27 pm
How did you hear about Mailcleaner: job

Re: MailCleaner 2017 "Jessie"/"Final" feedback

Postby FlorianB » Mon Sep 18, 2017 5:36 pm

snvdberg wrote:Also registering with spaces in last name doesn't work

Re-Hello,
We'll correct it quickly, thanks.
Regards,
Florian
FlorianB
Posts: 258
Joined: Wed Apr 01, 2015 2:27 pm
How did you hear about Mailcleaner: job

Re: MailCleaner 2017 "Jessie"/"Final" feedback

Postby FlorianB » Mon Sep 18, 2017 5:41 pm

DirkV wrote:I have noticed something else, authenticated users sending email are still checked against RBL's and get greylisted. This seems different in comparison to the 2014 environment.

Both are local domains within the same mailcleaner server.


2017-09-13 08:02:02 H=(SRVDOMOTICZ01) [2001:981:*******] X=TLSv1.2:ECDHE-RSA-AES256-GCM-SHA384:256 CV=no F=<domoticz@dv-networks.nl> A=fixed_login:domoticz@dv-networks.nl temporarily rejected RCPT <dirk@dirkv.nl>: greylisted (spf: none)


Hello DirkV,
I'll talk about thing I'm not entirely sure because i should check for 201410 code to be sure.
But: As far as I know, nothing change concerning this between both version, so maybe did you set some of your server in "Don't check these hosts" ? Or something similar.
Regards,
Florian

Return to “Feedback”

Who is online

Users browsing this forum: No registered users and 1 guest