MailCleaner 2017 "Jessie"/"Final" feedback

Give your impressions and feelings about MailCleaner

Moderators: FlorianB, Pascal, bourgeois, mentor

sangramshekhawat
Posts: 2
Joined: Thu Nov 23, 2017 7:54 am
How did you hear about Mailcleaner: WWW

Re: MailCleaner 2017 "Jessie"/"Final" feedback

Postby sangramshekhawat » Sun Nov 26, 2017 3:34 pm

Hi Florian,

Appreciate your reply. Yes the Wizard doesn't do anything. It will accept the default password and I will put new password (Reading the forums I assumed it wont accept any special characters etc, I kept it pretty simple as uppercase lower case and number combination) and then I wont be able to do anything further it will stay there. If I select the NEXT button on the right screen the wizard will loop back to first screen with message that you need to complete all steps of the wizard. I also see a message when I login to Mailcleaner about "using default password ". I am afraid of running the wizard again coz it repeats in loop. I also saw another issue in ESXi 6.0 Console its weird, keyboard layout is having issue e.g. Letter Y is showing Z and Letter "&" (shift+ 7) is "/" (Forward slash) there are many such cases it is very difficult to work specially when your password has those special characters. I can share the details if you need. However working on console is not a priority as of now. I would rather focus on Wizard. Please let me know if you need any information from me.

Sangram
masterit
Posts: 17
Joined: Tue Oct 13, 2015 4:43 pm
How did you hear about Mailcleaner: Spiceworks forum

Re: MailCleaner 2017 "Jessie"/"Final" feedback

Postby masterit » Sun Dec 03, 2017 7:22 am

i used this link to setup a cf file with custom scores.
https://support.mailcleaner.net/boards/3/topics/51-how-to-create-custom-spamc-rules

the rule name is the same as in the link: 99_custom_rules.cf
there arent any rules with a higher number than that one.

restarted the filtering service but the new scores i set aren't being followed..
when i look at the emails that get marked as spam the score they received are the original one's set by scores.cf not the customized ones.

these are what the scores i set should be.

Code: Select all

score RDNS_NONE 0
score BOTNET_BADDNS 0
score BOTNET_IPINHOSTNAME 0
score BOTNET_CLIENTWORDS 0.1
score BOTNET_CLIENT 0.1
score DEAR_SOMETHING 2.5
uncltom
Posts: 525
Joined: Tue Aug 26, 2008 3:01 am
How did you hear about Mailcleaner: I dont remember probably google?
Location: Spokane, WA

Re: MailCleaner 2017 "Jessie"/"Final" feedback

Postby uncltom » Fri Dec 15, 2017 7:03 am

PKej,

I am running mailcleaner 2017 and I have NEVER ran resync_db.sh.
My default installation went fine.

Uncltom

PKej wrote:
When did you do all of this ?

Yesterday and today before writing first feedback. OK, so I did resync_db:

Code: Select all

root@mailcleaner:~# /usr/mailcleaner/bin/resync_db.sh
starting slave db...
  Starting slave DB: started.
  Stopping slave DB: Wait for mysqld to exit
.
.
 stopped.
stopped.
  Starting slave DB: started.
  Stopping slave DB: Wait for mysqld to exit
 stopped.
stopped.
  Starting slave DB: started.



then:

Code: Select all

root@mailcleaner:~# echo 'show slave status\G' |/usr/mailcleaner/bin/mc_mysql -s mc_config
*************************** 1. row ***************************
               Slave_IO_State: Waiting for master to send event
                  Master_Host: 127.0.0.1
                  Master_User: mailcleaner
                  Master_Port: 3306
                Connect_Retry: 60
              Master_Log_File: mysql_bin.000048
          Read_Master_Log_Pos: 4705
               Relay_Log_File: mysqldslave-relay-bin.000004
                Relay_Log_Pos: 253
        Relay_Master_Log_File: mysql_bin.000048
             Slave_IO_Running: Yes
            Slave_SQL_Running: Yes
              Replicate_Do_DB: mc_config
          Replicate_Ignore_DB: mc_spool
           Replicate_Do_Table:
       Replicate_Ignore_Table: mc_config.update_patch
      Replicate_Wild_Do_Table:
  Replicate_Wild_Ignore_Table:
                   Last_Errno: 0
                   Last_Error:
                 Skip_Counter: 0
          Exec_Master_Log_Pos: 4705
              Relay_Log_Space: 415
              Until_Condition: None
               Until_Log_File:
                Until_Log_Pos: 0
           Master_SSL_Allowed: No
           Master_SSL_CA_File:
           Master_SSL_CA_Path:
              Master_SSL_Cert:
            Master_SSL_Cipher:
               Master_SSL_Key:
        Seconds_Behind_Master: 0
Master_SSL_Verify_Server_Cert: No
                Last_IO_Errno: 0
                Last_IO_Error:
               Last_SQL_Errno: 0
               Last_SQL_Error:
  Replicate_Ignore_Server_Ids:
             Master_Server_Id: 11


after this I did /etc/init.d/mailcleaner restart and now it look like it should work. I'll test it at evening.

EDIT:
FlorianB: It's working now, thank you again! :) But I am sorry I must consider default installation as broken. MC isn't working at all without running /usr/mailcleaner/bin/resync_db.sh! First thing I did after starting fresh VM was running MCupdater and apt upgrade so I had newest version of MC before configuring MC by wizard and admin site.
Pentangle
Posts: 85
Joined: Thu Jan 31, 2013 1:20 am
How did you hear about Mailcleaner: Googling

Re: MailCleaner 2017 "Jessie"/"Final" feedback

Postby Pentangle » Fri Dec 29, 2017 4:37 pm

Hi,

When trying to install the community tools prior to upgrading a 2014.x cluster to 2017, I get the following:

Code: Select all

root@mailcleaner:~# cd && git clone https://github.com/MailCleaner/MailCleaner-Community-Tools.git
-bash: git: command not found


Any idea?
uncltom
Posts: 525
Joined: Tue Aug 26, 2008 3:01 am
How did you hear about Mailcleaner: I dont remember probably google?
Location: Spokane, WA

Re: MailCleaner 2017 "Jessie"/"Final" feedback

Postby uncltom » Sat Dec 30, 2017 3:21 am

Pentangle wrote:Hi,

When trying to install the community tools prior to upgrading a 2014.x cluster to 2017, I get the following:

Code: Select all

root@mailcleaner:~# cd && git clone https://github.com/MailCleaner/MailCleaner-Community-Tools.git
-bash: git: command not found


Any idea?


Try apt-get install git first. You may want to review how to do the upgrade there may be other tools that are necessary.
Did you try the official update procedure to 2014?

> apt-get update
> apt-get upgrade
> cd /usr/mailcleaner
> cvs -q update -dP
> source lib/updates/update_binaries.sh
> stabilizeBinaries
> install/install_perl_libs.sh
> install/install_sa.sh
> /usr/mailcleaner/bin/check_db.pl --update
> /etc/init.d/mailcleaner restart
uncltom
Posts: 525
Joined: Tue Aug 26, 2008 3:01 am
How did you hear about Mailcleaner: I dont remember probably google?
Location: Spokane, WA

Re: MailCleaner 2017 "Jessie"/"Final" feedback

Postby uncltom » Sat Dec 30, 2017 3:25 am

sangramshekhawat wrote:Hi Florian,

Appreciate your reply. Yes the Wizard doesn't do anything. It will accept the default password and I will put new password (Reading the forums I assumed it wont accept any special characters etc, I kept it pretty simple as uppercase lower case and number combination) and then I wont be able to do anything further it will stay there. If I select the NEXT button on the right screen the wizard will loop back to first screen with message that you need to complete all steps of the wizard. I also see a message when I login to Mailcleaner about "using default password ". I am afraid of running the wizard again coz it repeats in loop. I also saw another issue in ESXi 6.0 Console its weird, keyboard layout is having issue e.g. Letter Y is showing Z and Letter "&" (shift+ 7) is "/" (Forward slash) there are many such cases it is very difficult to work specially when your password has those special characters. I can share the details if you need. However working on console is not a priority as of now. I would rather focus on Wizard. Please let me know if you need any information from me.

Sangram


It sounds like your keyboard layout is not correct try dpkg-reconfigure keyboard-configuration
Pentangle
Posts: 85
Joined: Thu Jan 31, 2013 1:20 am
How did you hear about Mailcleaner: Googling

Re: MailCleaner 2017 "Jessie"/"Final" feedback

Postby Pentangle » Wed Jan 03, 2018 1:38 pm

uncltom wrote:
Pentangle wrote:Hi,

When trying to install the community tools prior to upgrading a 2014.x cluster to 2017, I get the following:

Code: Select all

root@mailcleaner:~# cd && git clone https://github.com/MailCleaner/MailCleaner-Community-Tools.git
-bash: git: command not found


Any idea?


Try apt-get install git first. You may want to review how to do the upgrade there may be other tools that are necessary.
Did you try the official update procedure to 2014?

> apt-get update
> apt-get upgrade
> cd /usr/mailcleaner
> cvs -q update -dP
> source lib/updates/update_binaries.sh
> stabilizeBinaries
> install/install_perl_libs.sh
> install/install_sa.sh
> /usr/mailcleaner/bin/check_db.pl --update
> /etc/init.d/mailcleaner restart



Thanks - yes these instances of mailcleaner have been around since the 2010 version so have always been upgraded that way, they just don't seem to have inherited git along the way.
Paladinemishakal
Posts: 22
Joined: Thu Sep 20, 2012 9:36 am
How did you hear about Mailcleaner: Work

Re: MailCleaner 2017 "Jessie"/"Final" feedback

Postby Paladinemishakal » Wed Jan 10, 2018 10:44 am

Hi All,

I have a clustered MC Community Edition 2014.10 running on ESXi 6.0 and I know that there is a new version 2017.09. I have review this topic and have the following questions:
1. What is the steps to upgrade from 2014.10 to 2017.09? I understand that if you are doing a fresh install, you can get one of the VMs format to do but what about upgrading from an existing version? or should I do a fresh install on another VM and then do a cluster migration?
2. Are there any steps for doing a cluster migration?
3. Assumming I want to upgrade an existing installation, should I be upgrading the OS first?
4. Will the migration script also migrate existing data (eg. quarantined emails)? If not, what is needed to migrate those over to the new server?

Thanks & Regards.
kmv
Posts: 42
Joined: Mon Sep 07, 2015 9:06 am
How did you hear about Mailcleaner: googling

Re: MailCleaner 2017 "Jessie"/"Final" feedback

Postby kmv » Thu Feb 01, 2018 1:32 pm

kmv wrote:Reports are empty.

When i manually send reports:

Code: Select all

root@mx:/usr/mailcleaner# /usr/mailcleaner/bin/send_summary.pl user@ofmydomain.org 0 1
2017-10-20 10:05:51 SUMSENT to user@ofmydomain.org for user@ofmydomain.org (days: 1, spams: 1, id: 1e5RNP-0002cE-3m)


I have recieved empty reports without any content. :shock:


Update: if user never logged into the user interface, then reports are empty. But if user once logged into the user interface, then Reports are good.

:?:
opg1987
Posts: 46
Joined: Thu Dec 17, 2015 12:14 pm
How did you hear about Mailcleaner: Colleague

Re: MailCleaner 2017 "Jessie"/"Final" feedback

Postby opg1987 » Mon Feb 26, 2018 12:45 pm

FlorianB wrote:
PKej wrote:I can't remember if it was enabled by default maybe I did enable it. But yes, even when I disabled it yesterday in configuration listed in previous post, filtering still uses dnsbl.sorbs.net.


Hello,
Exact this is not enabled by default but if you enabled it and it doesn't disable correctly now, it should be a database synchronization problem.
launch a /usr/mailcleaner/bin/resync_db.sh and then redisable it, then restart at least filtering (or all MailCleaner). It should be resolved.

This is issue is happening to me. These steps to resync DB haven't fixed it for me.

Any other ideas on how to resolve?

I've created a thread about it here:
viewtopic.php?f=12&t=2614&p=11097
uncltom
Posts: 525
Joined: Tue Aug 26, 2008 3:01 am
How did you hear about Mailcleaner: I dont remember probably google?
Location: Spokane, WA

Re: MailCleaner 2017 "Jessie"/"Final" feedback

Postby uncltom » Tue Feb 27, 2018 7:54 pm

Pentangle wrote:
uncltom wrote:
Pentangle wrote:Hi,

When trying to install the community tools prior to upgrading a 2014.x cluster to 2017, I get the following:

Code: Select all

root@mailcleaner:~# cd && git clone https://github.com/MailCleaner/MailCleaner-Community-Tools.git
-bash: git: command not found


Any idea?


Try apt-get install git first. You may want to review how to do the upgrade there may be other tools that are necessary.
Did you try the official update procedure to 2014?

> apt-get update
> apt-get upgrade
> cd /usr/mailcleaner
> cvs -q update -dP
> source lib/updates/update_binaries.sh
> stabilizeBinaries
> install/install_perl_libs.sh
> install/install_sa.sh
> /usr/mailcleaner/bin/check_db.pl --update
> /etc/init.d/mailcleaner restart



Thanks - yes these instances of mailcleaner have been around since the 2010 version so have always been upgraded that way, they just don't seem to have inherited git along the way.


What happens if you do an apt-get install git? I didn't do an upgrade but started over with a clean install so I haven't seen how this should work. I ported my spam folders over and did a resync_spams.pl to bring them in to the database after recreating the domains. (All 5 of them so this actually worked for me :-) )
Pentangle
Posts: 85
Joined: Thu Jan 31, 2013 1:20 am
How did you hear about Mailcleaner: Googling

Re: MailCleaner 2017 "Jessie"/"Final" feedback

Postby Pentangle » Wed Feb 28, 2018 12:45 pm

This is what happens...

Code: Select all

root@mailcleaner:~# apt-get install git
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following extra packages will be installed:
  libcurl3-gnutls
Suggested packages:
  git-doc git-arch git-cvs git-svn git-email git-daemon-run git-gui gitk
  gitweb
The following NEW packages will be installed:
  git libcurl3-gnutls
0 upgraded, 2 newly installed, 0 to remove and 0 not upgraded.
Need to get 5,122 kB of archives.
After this operation, 10.7 MB of additional disk space will be used.
Do you want to continue [Y/n]? y
WARNING: The following packages cannot be authenticated!
  libcurl3-gnutls git
Install these packages without verification [y/N]? y
Err http://ftp.debian.org/debian/ squeeze/main git i386 1:1.7.2.5-3
  404  Not Found [IP: 130.89.148.12 80]
Err http://http.debian.net/debian/ squeeze-lts/main libcurl3-gnutls i386 7.21.0-2.1+squeeze12
  404  Not Found [IP: 151.101.16.204 80]
Failed to fetch http://http.debian.net/debian/pool/main/c/curl/libcurl3-gnutls_7.21.0-2.1+squeeze12_i386.deb  404  Not Found [IP: 151.101.16.204 80]
Failed to fetch http://ftp.debian.org/debian/pool/main/g/git/git_1.7.2.5-3_i386.deb  404  Not Found [IP: 130.89.148.12 80]
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?
uncltom
Posts: 525
Joined: Tue Aug 26, 2008 3:01 am
How did you hear about Mailcleaner: I dont remember probably google?
Location: Spokane, WA

Re: MailCleaner 2017 "Jessie"/"Final" feedback

Postby uncltom » Thu Mar 01, 2018 8:16 am

Pentangle wrote:This is what happens...

Code: Select all

root@mailcleaner:~# apt-get install git
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following extra packages will be installed:
  libcurl3-gnutls
Suggested packages:
  git-doc git-arch git-cvs git-svn git-email git-daemon-run git-gui gitk
  gitweb
The following NEW packages will be installed:
  git libcurl3-gnutls
0 upgraded, 2 newly installed, 0 to remove and 0 not upgraded.
Need to get 5,122 kB of archives.
After this operation, 10.7 MB of additional disk space will be used.
Do you want to continue [Y/n]? y
WARNING: The following packages cannot be authenticated!
  libcurl3-gnutls git
Install these packages without verification [y/N]? y
Err http://ftp.debian.org/debian/ squeeze/main git i386 1:1.7.2.5-3
  404  Not Found [IP: 130.89.148.12 80]
Err http://http.debian.net/debian/ squeeze-lts/main libcurl3-gnutls i386 7.21.0-2.1+squeeze12
  404  Not Found [IP: 151.101.16.204 80]
Failed to fetch http://http.debian.net/debian/pool/main/c/curl/libcurl3-gnutls_7.21.0-2.1+squeeze12_i386.deb  404  Not Found [IP: 151.101.16.204 80]
Failed to fetch http://ftp.debian.org/debian/pool/main/g/git/git_1.7.2.5-3_i386.deb  404  Not Found [IP: 130.89.148.12 80]
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?


You're going to need to change your apt sources.list to contain:

deb http://archive.debian.org/debian squeeze main
deb http://archive.debian.org/debian squeeze-lts main

See https://wiki.debian.org/DebianSqueeze

That should get you going.
Pentangle
Posts: 85
Joined: Thu Jan 31, 2013 1:20 am
How did you hear about Mailcleaner: Googling

Re: MailCleaner 2017 "Jessie"/"Final" feedback

Postby Pentangle » Tue Mar 06, 2018 12:11 am

I've managed to install GIT now, but I still have questions about the upgrade process:

I have 5 machines in a cluster. Unfortunately the cluster master is a 32bit variant whereas the other slaves that actually do all the mail processing are 64bit. In which order should I upgrade the cluster? master first or slaves first?

Also, since the master is 32bit I should really blow it away and install a 64bit version going forwards - does this upgrade path cater for this eventuality?

Hence, If I find myself unable to update this cluster, how do I take the domains and config to a fresh Jessie install to proceed that way?

Thanks,
Mike.
FlorianB
Posts: 296
Joined: Wed Apr 01, 2015 2:27 pm
How did you hear about Mailcleaner: job

Re: MailCleaner 2017 "Jessie"/"Final" feedback

Postby FlorianB » Tue Mar 06, 2018 12:27 pm

Hello Pentangle,

As 32bits is not supported anymore (as for Enterprise Edition), you'll have to install a new fresh master and transfer your old one to the new one.
You can follow this to help yourself during those steps:
https://support.mailcleaner.net/boards/ ... ailcleaner
Order (master or slaves first) is not relevant here but i would suggest to do the master first as it need to be reinstalled anyway.

If you want to reinstall a new parrallel cluster and simply import Domains, Users and their parameters (db accounts and whitelists too if i remember well), you can use the import script present in community tools repository on github: https://github.com/MailCleaner/MailClea ... nity-Tools
The first solution would avoid you to loose quarantines.

Regards,
Florian

Return to “Feedback”

Who is online

Users browsing this forum: No registered users and 3 guests