Unable to patch 2007011901

Generic questions on MailCleaner usage. Please check if your question cannot find a more specific topic below before posting here !<br>
This section is now READ ONLY, please choose the section below that fit your question !

Moderators: FlorianB, Pascal, bourgeois, mentor

gt
Posts: 52
Joined: Wed Jan 24, 2007 10:48 am

Unable to patch 2007011901

Postby gt » Wed Jan 24, 2007 2:10 pm

Hello,

when I applying the patch 2007011901, it show the error message

could not fetch packages list ABORTED

anythings wrong?

I wan to rerun it, however it prompt me already apply.
the_fbi
Posts: 49
Joined: Sat Dec 09, 2006 11:28 am
Location: Oxfordshire, UK

Postby the_fbi » Wed Jan 24, 2007 7:41 pm

This patch downloads quite a lot from debian mirrors and Sourceforge too.

Read this thread http://forum.mailcleaner.org/viewtopic.php?t=180 in order to be able to re-apply the patch.

There will be a logfile for the failed patch in /var/log/ which may help you diagnose the problem too.

Edit: Noticed this is a 2007 patch, missread it as the large 200611 patch. Not done this one (2007) yet myself so actually I have no idea of its size or if it works. Sorry.
gt
Posts: 52
Joined: Wed Jan 24, 2007 10:48 am

Postby gt » Wed Jan 24, 2007 10:30 pm

ooh.. ok.

Probably anybody done the patch before?
the_fbi
Posts: 49
Joined: Sat Dec 09, 2006 11:28 am
Location: Oxfordshire, UK

Postby the_fbi » Wed Jan 24, 2007 10:55 pm

Is that patch filename definately correct?
Latest on the website is showing
Latest patch is: 2006111701

Edit: OK, checked the CVS, your update does exist, website hasn't been updated.

I'll give it a go at the office tomorrow, don't want to do it remotely....

What does the patch logfile in /var/log say?
gt
Posts: 52
Joined: Wed Jan 24, 2007 10:48 am

Postby gt » Wed Jan 24, 2007 11:32 pm

the error is the one tht i published.

you have a look in the announcement in this forum, http://forum.mailcleaner.org/viewtopic.php?t=179

this is the latest patch. it will upgrade your system to php5.

let me know if you successful upgrade the patch.
the_fbi
Posts: 49
Joined: Sat Dec 09, 2006 11:28 am
Location: Oxfordshire, UK

Postby the_fbi » Thu Jan 25, 2007 7:57 am

gt wrote:you have a look in the announcement in this forum, http://forum.mailcleaner.org/viewtopic.php?t=179

http://forum.mailcleaner.org/viewtopic.php?t=179 is the old update from 17th November 2006, this is not the one you're having an issue with.
olivier
Posts: 1348
Joined: Thu Jan 01, 1970 1:00 am
Contact:

Postby olivier » Thu Jan 25, 2007 8:05 am

this is a beta patch. I'm about to release it, but waiting for some third parties software updates to be included.
It will surely not have the same number, so even if you applied this, you will get the new one.
gt
Posts: 52
Joined: Wed Jan 24, 2007 10:48 am

Postby gt » Thu Jan 25, 2007 8:08 am

hi,

how can we know that it is beta release or final release? coz we may have to choose only final release to be upload to production system.
olivier
Posts: 1348
Joined: Thu Jan 01, 1970 1:00 am
Contact:

Postby olivier » Thu Jan 25, 2007 8:14 am

because it has not been announced :wink:
wait on the official announcement on the website, or on the forum to apply any patch
gt
Posts: 52
Joined: Wed Jan 24, 2007 10:48 am

Postby gt » Thu Jan 25, 2007 8:17 am

hi,

Thanks for the prompt reply. A surprise to me. Thanks a lot.

BTW, would this one of cause of my Service Critical isssue at another thread?
olivier
Posts: 1348
Joined: Thu Jan 01, 1970 1:00 am
Contact:

Postby olivier » Thu Jan 25, 2007 8:20 am

maybe, try this:

Code: Select all

> aptitude install mc-greylistd mc-mailscanner at mc-ocr libssl-dev gocr libungif-bin imagemagick mc-libs mc-exim
gt
Posts: 52
Joined: Wed Jan 24, 2007 10:48 am

Postby gt » Thu Jan 25, 2007 9:28 am

ooh.. i already reformat it out.. may be hv to find another machine to try.

Return to “General help”

Who is online

Users browsing this forum: No registered users and 1 guest