HELP ! ! ! Could not download updating packages

Generic questions on MailCleaner usage. Please check if your question cannot find a more specific topic below before posting here !<br>
This section is now READ ONLY, please choose the section below that fit your question !

Moderators: FlorianB, Pascal, bourgeois, mentor

IainG
Posts: 7
Joined: Thu Dec 14, 2006 9:17 am

HELP ! ! ! Could not download updating packages

Postby IainG » Thu Jan 04, 2007 3:35 pm

I tried running the last update 2006111701 and it came back with an aborted message

Could not download updating packages.

I cant get anything through the web interface without getting database errors ?

How can I get round this
olivier
Posts: 1348
Joined: Thu Jan 01, 1970 1:00 am
Contact:

Postby olivier » Thu Jan 04, 2007 3:46 pm

are you sure your MailCleaner can connect to the outside world on ports 80, 443, 22 and 2401 (forgot this one in the doc sorry).

then check this (in the FAQ): http://forum.mailcleaner.org/viewtopic.php?t=180
nlj
Posts: 4
Joined: Thu Jan 04, 2007 1:12 pm

Same here

Postby nlj » Thu Jan 04, 2007 3:52 pm

Installed on two virtual machines and things go bad when I try to apply the 2006111701 patch (which does not complete).

Tried applying the patch again:

Code: Select all

mailcleaner:/usr/mailcleaner/updates# ./2006111701
could not download upgraded packages


Anybody knows how to deal with this?

Regards
Niklas
IainG
Posts: 7
Joined: Thu Dec 14, 2006 9:17 am

Postby IainG » Thu Jan 04, 2007 3:52 pm

It should be fine,

I built the same system 2 / 3 times before christmas ( getting familiar with it ) and the patches pulled down and applied fine ??

I know nothing else has changed as I manage the network and all the servers.

Something to note, when i rebooted the server it said my mailcleaner.cf file was a newer version that the bersion of mailcleaner running ?

?
olivier
Posts: 1348
Joined: Thu Jan 01, 1970 1:00 am
Contact:

Postby olivier » Thu Jan 04, 2007 3:56 pm

try:

Code: Select all

> aptitude update
> aptitude upgrade


this should give you the error.
IainG
Posts: 7
Joined: Thu Dec 14, 2006 9:17 am

Postby IainG » Thu Jan 04, 2007 4:13 pm

Looks like there are problems pulling files from osmailcleaner.sourceforge.net

When i tried aptitude update ir came back with ign next to that site.
then carrying out an aptitude upgrade.

Then it came back with 'Error reading from server. remote end connection closed" for mc-httpd
nlj
Posts: 4
Joined: Thu Jan 04, 2007 1:12 pm

Looks better

Postby nlj » Thu Jan 04, 2007 4:18 pm

I've had some luck.

Tried:

Code: Select all

> aptitude update
> aptitude upgrade

whitch showed problems downloading the mc-httpd package.
So I tried 5-6 times and finally got the package to install succesfully.

After that the web UI looked fine.

Then I tried to reinstall the patch 2006111701 but it still fails.

Code: Select all

mailcleaner:/usr/mailcleaner/updates# ./2006111701
could not install packages
ABORTED


Anyway, the web UI looks fine and reports 2006111701 as last patch (?).

/Niklas
olivier
Posts: 1348
Joined: Thu Jan 01, 1970 1:00 am
Contact:

Postby olivier » Thu Jan 04, 2007 4:25 pm

if all services are up, then it's ok.

There seems to be another problem at sourceforge. I'm sorry about that, but I can't actually afford putting this on our lines.
And I didn't had time to search for bring up some mirroring for the binaries.

Hope the problems will be solved soon ! sorry again.
IainG
Posts: 7
Joined: Thu Dec 14, 2006 9:17 am

Postby IainG » Thu Jan 04, 2007 4:30 pm

Just kept retrying and finally just got it.

Thanks for the pointers :D

all back and running again :lol:

Return to “General help”

Who is online

Users browsing this forum: No registered users and 1 guest