Can't join cluster on 2017.09 Jessie

Problems/questions regarding the MailCleaner configuration

Moderators: FlorianB, Pascal, bourgeois, mentor

Posts: 16
Joined: Thu Jan 19, 2012 9:53 pm
How did you hear about Mailcleaner: Google Barracuda replacement

Can't join cluster on 2017.09 Jessie

Postby jbeard » Mon Nov 13, 2017 9:35 pm

Clean install of two new machines. I've run /usr/mailcleaner/scripts/configuration/ on the master and slave. Verified that the password is correct in /etc/mailcleaner.conf on both.

When I try and add the slave, I get this error:

Code: Select all

mysqldump: Got error: 1045: Access denied for user 'mailcleaner'@'' (using password: YES) when trying to connect

/mc_mysql -m mc_config and /mc_mysql -s mc_config show no issues. I ran the updater before running the setup wizard. I've tried using DNS names for hostnames as well as IPs.

I've tried resyncing the dbs as well. No luck. Any ideas?

Return to “Configuration”

Who is online

Users browsing this forum: Baidu [Spider] and 5 guests