Writing the DNS name redirects to https://mailcleaner

Problems/questions regarding MailCleaner installation

Moderators: Pascal, mentor, FlorianB, bourgeois

danielhansson
Posts: 9
Joined: Wed Aug 30, 2017 7:29 am
How did you hear about Mailcleaner: My company uses it

Writing the DNS name redirects to https://mailcleaner

Postby danielhansson » Wed Nov 01, 2017 6:20 pm

Hi!

I'm trying to deploy a fresh Mailcleaner 2017 edition. I have imported the domains, and double and tripple checked all the settings from the old install but I still can't get it to work.

The problem
I want to use domain.example.com but as soon as I write that in the browser and hit enter, I get automatically redirected to https://mailcleaner.

I have tried to change the apache config, but as soon as it reloads it sets the old values again. So back to square one. I also tried:
  • Clearing cache in the browser
  • echo "USE mc_config; UPDATE httpd_config SET servername='your_server_name';" | /usr/mailcleaner/bin/mc_mysql -m
  • Change /etc/hosts
  • set-hostname
  • Googling for the whole day (8 hours)

How do I fix this, and where do I need to change to make mailcleaner understand the new DNS name? I'm kind of frustrated by now and I'm a Debian user since some years now.

Side note about Let's Encrypt
And a bonus, it is possible to install Let's Encrypt from git, read somewhere that ppl used scripts and stuff, but git clone worked. Then just use the certs from .../live/domain.example.com as they are not changed over time, and then add them in the WebGUI. Never got it working, but at least it's possible to install via git.

Looking forward to have LE implemented as a script in the future. I use this myself in the Nextcloud VM that I develop: https://github.com/nextcloud/vm/blob/ma ... ate-ssl.sh

servername mailcleaner hostname base_url

Return to “Installation”

Who is online

Users browsing this forum: No registered users and 1 guest