VMware Appliance fails OVA -Unsupported hardware vmx-12

Problems/questions regarding MailCleaner installation

Moderators: FlorianB, Pascal, bourgeois, mentor

asowry
Posts: 2
Joined: Wed Sep 13, 2017 2:26 pm
How did you hear about Mailcleaner: google

VMware Appliance fails OVA -Unsupported hardware vmx-12

Postby asowry » Wed Sep 13, 2017 11:11 pm

Hi Guys and Gals
I have just been tasked with evaluation of this and after some reading, it seems like a great product
this maybe a real newbie question, but I can not for the get this installed
Running VMWare ESX 6 on main development server and lots of spare resources, and very vanilla setup, except it connects to the core with dual 10GB interfaces that vlan to the lab, and all that is at the VM level so can't see it being an issue, but best to describe it guess

my process as long as it was .....

I downloaded the OVA,
Checked MD5
Ran
File>>
Deploy OVF template
Selected the image (MailCleaner.ova) .. Next and ...

Error
This OVF Package uses features that are not supported when deploying directly to and ESX Host
THe OVF package requires unsuporte4d hardware.
Details: Line 24 Unsuported hardware family 'VMX-12'.

i dont really understand the error file, thus the question here i guess, but when reading it, it seems that it wants USB and Sound etc and would that be the issue?

Thanks in advance for you help

Andrew

I Include the detail error
<!--Generated by VMware ovftool 4.1.0 (build-3634792), UTC time: 2017-09-07T09:00:11.003519Z
-->
-<Envelope xmlns="http://schemas.dmtf.org/ovf/envelope/1" xmlns:cim="http://schemas.dmtf.org/wbem/wscim/1/common" xmlns:ovf="http://schemas.dmtf.org/ovf/envelope/1" xmlns:rasd="http://schemas.dmtf.org/wbem/wscim/1/cim-schema/2/CIM_ResourceAllocationSettingData" xmlns:vmw="http://www.vmware.com/schema/ovf" xmlns:vssd="http://schemas.dmtf.org/wbem/wscim/1/cim-schema/2/CIM_VirtualSystemSettingData" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" vmw:buildId="build-3634792">
-<References>
<File ovf:href="MailCleaner-disk1.vmdk" ovf:id="file1" ovf:size="2647305728"/>
</References>
-<DiskSection>
<Info>Virtual disk information</Info>
<Disk ovf:capacity="60" ovf:capacityAllocationUnits="byte * 2^30" ovf:diskId="vmdisk1" ovf:fileRef="file1" ovf:format="http://www.vmware.com/interfaces/specifications/vmdk.html#streamOptimized" ovf:populatedSize="5866520576"/>
</DiskSection>
-<NetworkSection>
<Info>The list of logical networks</Info>
-<Network ovf:name="bridged">
<Description>The bridged network</Description>
</Network>
</NetworkSection>
-<VirtualSystem ovf:id="vm">
<Info>A virtual machine</Info>
<Name>MailCleaner</Name>
-<OperatingSystemSection ovf:id="1" vmw:osType="otherGuest">
<Info>The kind of installed guest operating system</Info>
</OperatingSystemSection>
-<VirtualHardwareSection>
<Info>Virtual hardware requirements</Info>
-<System>
<vssd:ElementName>Virtual Hardware Family</vssd:ElementName>
<vssd:InstanceID>0</vssd:InstanceID>
<vssd:VirtualSystemIdentifier>MailCleaner</vssd:VirtualSystemIdentifier>
<vssd:VirtualSystemType>vmx-12</vssd:VirtualSystemType>
</System>
-<Item>
<rasd:AllocationUnits>hertz * 10^6</rasd:AllocationUnits>
<rasd:Description>Number of Virtual CPUs</rasd:Description>
<rasd:ElementName>4 virtual CPU(s)</rasd:ElementName>
<rasd:InstanceID>1</rasd:InstanceID>
<rasd:ResourceType>3</rasd:ResourceType>
<rasd:VirtualQuantity>4</rasd:VirtualQuantity>
</Item>
-<Item>
<rasd:AllocationUnits>byte * 2^20</rasd:AllocationUnits>
<rasd:Description>Memory Size</rasd:Description>
<rasd:ElementName>4096MB of memory</rasd:ElementName>
<rasd:InstanceID>2</rasd:InstanceID>
<rasd:ResourceType>4</rasd:ResourceType>
<rasd:VirtualQuantity>4096</rasd:VirtualQuantity>
</Item>
-<Item ovf:required="false">
<rasd:Address>0</rasd:Address>
<rasd:Description>USB Controller (EHCI)</rasd:Description>
<rasd:ElementName>usb</rasd:ElementName>
<rasd:InstanceID>3</rasd:InstanceID>
<rasd:ResourceSubType>vmware.usb.ehci</rasd:ResourceSubType>
<rasd:ResourceType>23</rasd:ResourceType>
<vmw:Config ovf:required="false" vmw:key="ehciEnabled" vmw:value="true"/>
</Item>
-<Item>
<rasd:Address>0</rasd:Address>
<rasd:Description>SCSI Controller</rasd:Description>
<rasd:ElementName>scsiController0</rasd:ElementName>
<rasd:InstanceID>4</rasd:InstanceID>
<rasd:ResourceSubType>lsilogic</rasd:ResourceSubType>
<rasd:ResourceType>6</rasd:ResourceType>
</Item>
-<Item>
<rasd:Address>1</rasd:Address>
<rasd:Description>IDE Controller</rasd:Description>
<rasd:ElementName>ideController1</rasd:ElementName>
<rasd:InstanceID>5</rasd:InstanceID>
<rasd:ResourceType>5</rasd:ResourceType>
</Item>
-<Item ovf:required="false">
<rasd:AutomaticAllocation>true</rasd:AutomaticAllocation>
<rasd:ElementName>serial0</rasd:ElementName>
<rasd:InstanceID>6</rasd:InstanceID>
<rasd:ResourceType>21</rasd:ResourceType>
<vmw:Config ovf:required="false" vmw:key="yieldOnPoll" vmw:value="true"/>
</Item>
-<Item ovf:required="false">
<rasd:AddressOnParent>0</rasd:AddressOnParent>
<rasd:AutomaticAllocation>false</rasd:AutomaticAllocation>
<rasd:ElementName>cdrom0</rasd:ElementName>
<rasd:InstanceID>7</rasd:InstanceID>
<rasd:Parent>5</rasd:Parent>
<rasd:ResourceType>15</rasd:ResourceType>
</Item>
-<Item>
<rasd:AddressOnParent>0</rasd:AddressOnParent>
<rasd:ElementName>disk0</rasd:ElementName>
<rasd:HostResource>ovf:/disk/vmdisk1</rasd:HostResource>
<rasd:InstanceID>8</rasd:InstanceID>
<rasd:Parent>4</rasd:Parent>
<rasd:ResourceType>17</rasd:ResourceType>
</Item>
-<Item>
<rasd:AddressOnParent>2</rasd:AddressOnParent>
<rasd:AutomaticAllocation>true</rasd:AutomaticAllocation>
<rasd:Connection>bridged</rasd:Connection>
<rasd:Description>E1000 ethernet adapter on "bridged"</rasd:Description>
<rasd:ElementName>ethernet0</rasd:ElementName>
<rasd:InstanceID>9</rasd:InstanceID>
<rasd:ResourceSubType>E1000</rasd:ResourceSubType>
<rasd:ResourceType>10</rasd:ResourceType>
<vmw:Config ovf:required="false" vmw:key="wakeOnLanEnabled" vmw:value="false"/>
</Item>
-<Item ovf:required="false">
<rasd:AutomaticAllocation>false</rasd:AutomaticAllocation>
<rasd:ElementName>sound</rasd:ElementName>
<rasd:InstanceID>10</rasd:InstanceID>
<rasd:ResourceSubType>vmware.soundcard.ensoniq1371</rasd:ResourceSubType>
<rasd:ResourceType>1</rasd:ResourceType>
</Item>
-<Item ovf:required="false">
<rasd:AutomaticAllocation>false</rasd:AutomaticAllocation>
<rasd:ElementName>video</rasd:ElementName>
<rasd:InstanceID>11</rasd:InstanceID>
<rasd:ResourceType>24</rasd:ResourceType>
</Item>
-<Item ovf:required="false">
<rasd:AutomaticAllocation>false</rasd:AutomaticAllocation>
<rasd:ElementName>vmci</rasd:ElementName>
<rasd:InstanceID>12</rasd:InstanceID>
<rasd:ResourceSubType>vmware.vmci</rasd:ResourceSubType>
<rasd:ResourceType>1</rasd:ResourceType>
</Item>
<vmw:Config ovf:required="false" vmw:key="cpuHotAddEnabled" vmw:value="true"/>
<vmw:Config ovf:required="false" vmw:key="powerOpInfo.powerOffType" vmw:value="soft"/>
<vmw:Config ovf:required="false" vmw:key="powerOpInfo.resetType" vmw:value="soft"/>
<vmw:Config ovf:required="false" vmw:key="powerOpInfo.suspendType" vmw:value="soft"/>
</VirtualHardwareSection>
</VirtualSystem>
</Envelope>
Attachments
vmerror.png
vmerror.png (10.8 KiB) Viewed 4202 times
asowry
Posts: 2
Joined: Wed Sep 13, 2017 2:26 pm
How did you hear about Mailcleaner: google

Re: VMware Appliance fails OVA -Unsupported hardware vmx-12

Postby asowry » Thu Sep 14, 2017 3:52 am

OK Here is an update for anyone else who may find this and not find anything else I fixed it as follows

I download VMware workstation (was v12 at this point) and deployed the OVF onto that, I whined about some hardware not being compatible click retry to ignore and move on
once it was installed I started the machine and it worked !! great so far
I then removed hardware that I did not need, sound card and USB
I then shut down the VM and exported to OVF from VM workstation to local drive (very slow btw so be prepared to wait)
then went to ESI and deployed OVF that I had created and started and it seems fine

ok so that's what it did, now what I think
I think that it was the sound card as I can not understand when you would won't that on a VM, but it seems to be good now so I will test and post an update later
FlorianB
Posts: 296
Joined: Wed Apr 01, 2015 2:27 pm
How did you hear about Mailcleaner: job

Re: VMware Appliance fails OVA -Unsupported hardware vmx-12

Postby FlorianB » Thu Sep 14, 2017 9:06 am

Hello,
Why not download the ESXi6 version directly ?
The OVF or Workstation will probably have less good performance as usual for ESXi. So i would recomment to download the good version as I managed to specifically make it compatible with ESXi 6.
Regards,
Florian
nightbird
Posts: 9
Joined: Wed Jul 05, 2017 10:57 am
How did you hear about Mailcleaner: Google
Location: France

Re: VMware Appliance fails OVA -Unsupported hardware vmx-12

Postby nightbird » Wed Sep 20, 2017 10:53 am

Hi

The other way is to convert ova in ovf using Vmware OFT Tool :

Code: Select all

ovftool.exe --lax source.ova destination.ovf


This command will create three files: a .MF file, an .OVF file and a .VMDK.
Open the .OVF file in a text editor and change all VirtualBox hardware.
Change this:

Code: Select all

<vssd:VirtualSystemType>vmx-12</vssd:VirtualSystemType>


By:

Code: Select all

<vssd:VirtualSystemType>vmx-11</vssd:VirtualSystemType>


Save and close. Now your edited file screwed the integrity check. To fix it calculate the SHA1 for the .OVF file (for example using sha1sum or fciv.exe (download), open the .MF file a substitute the present hash with the calculated one.

Source : https://jekil.sexy/blog/2015/this-ovf-p ... dware.html

Regards

Night
masterit
Posts: 17
Joined: Tue Oct 13, 2015 4:43 pm
How did you hear about Mailcleaner: Spiceworks forum

Re: VMware Appliance fails OVA -Unsupported hardware vmx-12

Postby masterit » Wed Oct 04, 2017 6:24 am

heads up the esxi version is corrupted. have downloaded it twice and am unable to use it in a vm. i've tried cloning the vmdk and get an error: Failed to clone disk: Read beyond end of object (1355). this leads me to beleive that the vmdk is corrupt.
dierk
Posts: 1
Joined: Thu Dec 27, 2012 9:59 pm
How did you hear about Mailcleaner: friends

Re: VMware Appliance fails OVA -Unsupported hardware vmx-12

Postby dierk » Sun Dec 31, 2017 1:29 am

Hello, one possibility is also after adapting the ovf file simply the * .mf checkum file to delete and then to import. With me it worked. dierk
Lesilhouette
Posts: 3
Joined: Fri Apr 29, 2016 8:35 am
How did you hear about Mailcleaner: Co-workers/friends

Re: VMware Appliance fails OVA -Unsupported hardware vmx-12

Postby Lesilhouette » Tue Jan 16, 2018 2:58 pm

I too have this problem! I downloaded and MD5 checked both the VMDK for ESXi and the OVA file multiple times, but both give errors on my ESXi 6 machine.
The VMDK cannot be accessed by the VM (although it's in the same directory as the other VM-files) when I connect the disk to the VM.

The OVA can't be deployed/imported because of the following error: "--1:-1VALUE_ILLEGAL: No supported hardware versions among [vmx-12]; supported: [vmx-04, vmx-07, vmx-08, vmx-09, vmx-10, vmx-11]."

Any fix for this (not a workaround by downloading a tool and extracting some files from it)?

Also: when can we expect the ISO installer?

Tnx.

Edit: by now they are aware of the VMDK and OVA for ESXi is not working, and they (or someone else) should make a new one (see this post: viewtopic.php?f=11&t=2530&p=11003#p11003)

Return to “Installation”

Who is online

Users browsing this forum: No registered users and 2 guests