Problems gettings VM working

Problems/questions regarding MailCleaner installation

Moderators: FlorianB, Pascal, bourgeois, mentor

Posts: 2
Joined: Tue Jan 09, 2018 3:27 pm
How did you hear about Mailcleaner: Google

Problems gettings VM working

Postby neonit » Wed Jan 10, 2018 10:40 am


i am using virtaul linux environment and wanted to get the latest version working. So i did the following steps:

1. I have downloaded the latest Virtual PC version:

Code: Select all


2. I unzipped the file and converted the VHD to a RAW file with the coommands:

Code: Select all

qemu-img convert -f vpc -O raw MailCleaner_VHD_LATEST.vhd MailCleaner_VHD_LATEST.raw

The 6 GB VHD was converted to a 60 GB RAW file.

3. Then i cloned the raw file to my hdd:

Code: Select all

dd if=/path/MailCleaner_VHD_LATEST.raw of=/dev/sda

This step tooked several hours, but the i rebooted the machine and it looked very good at first, but then i ran in several error messages:

The first error i got was at booting process, the message:

Code: Select all

systemd-udevd[60]: hwdb.bin does not exist, please run udevadm hwdb --update

Some other error messages in "dmesg" are:

Code: Select all

systemd[1]: Failed to start Load Kernel Modules.
intel_rapl: no valid rapl domains found in package 0

Then i saw that the process StatsDaemon is killed several times because of low memory:

Code: Select all

Out of memory: Kill process 2023 (StatsDaemon) score 984 or sacrifice child
Killed process 2023 (StatsDaemon) total-vm:12856500kB, anon-rss:5950924kB, file-rss:12kB

The machine has 6 GB RAM, so i thought it must be enough...

After connecting via SSH to the server it shows the default menu:

Code: Select all

MailCleaner: base system configuration
  ( 1) Keyboard configuration
  ( 2) Set root password (Optionnal: Connect to the web interface to access the configurator)
  ( 3) Network configuration (Optionnal: You could do this with the MailCleaner Web Interface)
  ( 4) Exit

Please enter the number of the element chosen [1]:

After pressing 4 for Exit the following message appears:

Code: Select all

touch: cannot touch ‘/var/mailcleaner/spool/mailcleaner/firstcmdlogin’: No such file or directory

So i was looking for that file and saw that the directory /var/mailcleaner does noch exist...

Next step i ran /root/Updater4MC/ and there also comes many messages that says that the directory /var/mailcleaner does not exist. So what should i do to get this thing working? ;)

- Thanks
Posts: 289
Joined: Thu Mar 07, 2013 2:12 am
How did you hear about Mailcleaner: google

Re: Problems gettings VM working

Postby cglmicro » Fri Jan 26, 2018 4:09 am


Return to “Installation”

Who is online

Users browsing this forum: Baidu [Spider] and 2 guests