Search found 28 matches

by madhopsman
Fri Jan 12, 2018 5:30 pm
Forum: Configuration
Topic: Using Letsencrypt certificate
Replies: 21
Views: 2664

Re: Using Letsencrypt certificate

... I don't get a clue because firewallrule "Windows Remote Management (HTTP-In)" regards to port 5985 and not 80 :-) Oops. Bad Copy/Paste. Fixed. I hope I have not forgotten a step, could you please check that madhopsman :D gr33tz Looks good to me. I guess the test is someone else trying...
by madhopsman
Fri Dec 22, 2017 4:24 pm
Forum: Configuration
Topic: Using Letsencrypt certificate
Replies: 21
Views: 2664

Re: Using Letsencrypt certificate

... The first condition of my script is an existing pfx file from LE and the second an existing openSSL.exe :) The script is a first draft so far, I do not like it 100% yet - but it works: cls ... I'm not certain why you are still re-encoding the output from OpenSSL. That may be why you are still g...
by madhopsman
Thu Dec 21, 2017 11:38 pm
Forum: Configuration
Topic: Using Letsencrypt certificate
Replies: 21
Views: 2664

Re: Using Letsencrypt certificate

Hi, you're right again!! Here we go, its ./exim_stage1/mainlog: 2017-12-21 22:55:54 no host name found for IP address my.ip.adr.ess 2017-12-21 22:55:54 TLS error on connection from (openssl.client.net) [my.ip.adr.ess] (SSL_CTX_use_PrivateKey_file file=/usr/mailcleaner/etc/apache/certs/SANCert-priv....
by madhopsman
Thu Dec 21, 2017 10:57 pm
Forum: Configuration
Topic: Using Letsencrypt certificate
Replies: 21
Views: 2664

Re: Using Letsencrypt certificate

Hi, ok, something doesn't work :( if i'm connecting to mailcleaner: OpenSSL> s_client -connect mailcleaner.my.externaldomain:25 -starttls smtp CONNECTED(00000220) 5184:error:140770FC:SSL routines:SSL23_GET_SERVER_HELLO:unknown protocol:.\ssl\s23_clnt.c:827: --- no peer certificate available --- No ...
by madhopsman
Thu Dec 21, 2017 2:21 pm
Forum: Configuration
Topic: Using Letsencrypt certificate
Replies: 21
Views: 2664

Re: Using Letsencrypt certificate

hi madhopsman, wonderful, thank you for your detailed explanation! that's exactly what I needed - I ignored the apache configuration. We're getting closer, I've a very good feeling :mrgreen: [EDIT] I got it now for apache - my apache is now up again, after a couple failures...encoding was wrong and...
by madhopsman
Thu Dec 21, 2017 5:26 am
Forum: Configuration
Topic: Using Letsencrypt certificate
Replies: 21
Views: 2664

Re: Using Letsencrypt certificate

Hi, I must have searched in wrong folder - the files are stored in "/usr/mailcleaner/etc/exim". Sorry. But it doesn't work. I found the variables "tls_certificate" and "tls_privatekey" in files "exim_stage1.conf_template", exim_stage2.conf_template and exim_s...
by madhopsman
Tue Dec 19, 2017 5:11 pm
Forum: Configuration
Topic: Using Letsencrypt certificate
Replies: 21
Views: 2664

Re: Using Letsencrypt certificate

Hello madhopsman, hello everyone, in MC2017 I cannot find the paths you mentioned. I'm going to "inject" my certificates, too - because another server collects my certificates from letsencrypt with a powershell script . After this, the pfx-file is splitted into private and public certific...
by madhopsman
Thu Dec 14, 2017 6:27 pm
Forum: Bugs and fixes
Topic: Error message (using default MC pw) appears but is wrong
Replies: 5
Views: 573

Re: Error message (using default MC pw) appears but is wrong

Just checking in to see if anyone had any update on the problem described in my issue above. :)
by madhopsman
Wed Dec 13, 2017 11:34 pm
Forum: Configuration
Topic: Using Letsencrypt certificate
Replies: 21
Views: 2664

Re: Using Letsencrypt certificate

I've been looking in to this as well. I was able to successfully replace the Apache SSL (externally generated and pushed via sFTP as PEM files, and changed the mailcleaner.conf_template under apache/sites) but this doesn't replace the certificate being used my EXIM. Can anyone point to the EXIM conf...
by madhopsman
Tue Nov 21, 2017 4:33 pm
Forum: Bugs and fixes
Topic: Error message (using default MC pw) appears but is wrong
Replies: 5
Views: 573

Re: Error message (using default MC pw) appears but is wrong

I am experiencing the same issue on "Jessie". However, this is due to the fact that 3 separate times when I tried to use the wizard to change all the passwords and tried to complete the process, I was no longer able to load the admin webpage or login (I could get to the login but as soon a...
by madhopsman
Thu Sep 25, 2014 10:30 pm
Forum: Updates
Topic: Shellshock vulnerability CVE-2014-6271 and CVE-2014-7169
Replies: 4
Views: 4721

Re: Shellshock vulnerability CVE-2014-6271 and CVE-2014-7169

First of all, there is no emergency in patching this since there is not exploitation possible on MailCleaner (>=2013.7). Anyway, MailCleaner can still be patched by using the following commands (on a fully up-to-date 2013.7): > echo "deb http://http.debian.net/debian/ squeeze-lts main contrib ...
by madhopsman
Thu Sep 25, 2014 6:21 pm
Forum: Updates
Topic: Shellshock vulnerability CVE-2014-6271 and CVE-2014-7169
Replies: 4
Views: 4721

Shellshock vulnerability CVE-2014-6271 and CVE-2014-7169

Latest Mailcleaner 2013 Community with all updates, but Bash is still vulnerable. No updates for bash showing in apt either. Should we be expecting to see an update for Squeeze soon?
by madhopsman
Fri Sep 12, 2014 1:31 am
Forum: Feedback
Topic: feedback on MailCleaner Community Edition 2013.7
Replies: 46
Views: 24507

Re: feedback on MailCleaner Community Edition 2013.7

Works again. FYI: The sources.list was empty, maybe messed up during the update process Just one more FYI, it actually wasnt working right away. exim was spitting up an error about being unable to locate the /var/mailcleaner/spool/tmp/domains.list and was giving 421 on all incoming messages. I ende...
by madhopsman
Thu Sep 11, 2014 10:20 pm
Forum: Feedback
Topic: feedback on MailCleaner Community Edition 2013.7
Replies: 46
Views: 24507

Re: AW: feedback on MailCleaner Community Edition 2013.7

del wrote:I'm home in a few minutes, prepare teamviewer please if you want to get some assistance


Thanks :D See PM
by madhopsman
Thu Sep 11, 2014 10:15 pm
Forum: Feedback
Topic: feedback on MailCleaner Community Edition 2013.7
Replies: 46
Views: 24507

Re: feedback on MailCleaner Community Edition 2013.7

no timeouts. If you look at my post just a bit ago, I put the output from running that. No errors, it just says there are no updates. :?

Go to advanced search