Search found 16 matches

by kranzfr3d
Sat Jan 20, 2018 12:07 pm
Forum: Updates
Topic: Update package mc-exim without verification?
Replies: 0
Views: 8

Update package mc-exim without verification?

Hello folks, the following question I get when updating my MC2017 - is it safe to update? Why there is no verification? root@myserver:~# sudo apt update && sudo apt upgrade Hit http://security.debian.org jessie/updates InRelease Ign http://ftp.debian.org jessie InRelease Hit http://ftp.debia...
by kranzfr3d
Fri Dec 29, 2017 12:43 am
Forum: Configuration
Topic: Using Letsencrypt certificate
Replies: 21
Views: 2345

Re: Using Letsencrypt certificate

Hi, here are my experiences regarding my Windows 2016 with Exchange 2016 server talking to MC this way : Step 1: get PFX with exportable private key from lets encrypt Step 2: split the PFX into "fullchain.pem" and "privkey.pem" Step 3: upload them both onto MC Step 4: change the ...
by kranzfr3d
Thu Dec 28, 2017 10:30 pm
Forum: Configuration
Topic: How to integrate MC in exchange?
Replies: 6
Views: 414

Re: How to integrate MC in exchange?

Hi,

thanks for your food for thought, my config is now live with this simplified sketch see attachment.


gr33tz
by kranzfr3d
Tue Dec 26, 2017 12:54 pm
Forum: Configuration
Topic: How to integrate MC in exchange?
Replies: 6
Views: 414

Re: How to integrate MC in exchange?

Hello,

*bump*.
I got the debian-changing hostname for my own:

Code: Select all

sudo hostnamectl set-hostname newHostname
sudo vi /etc/hostname
sudo vi /etc/hosts
sudo shutdown -r now OR sudo /etc/init.d/networking restart



gr33tz
by kranzfr3d
Sun Dec 24, 2017 12:10 am
Forum: Configuration
Topic: Using Letsencrypt certificate
Replies: 21
Views: 2345

Re: Using Letsencrypt certificate

hi, I just wanted to let you know - I solved all issues into my LE-cert-injection chain from MX to MC - thanks a lot. From another linux system I got "Verify return code: 0 (ok)" when checking the smtp ssl certificate. I'm going to update my earlier posts and this one after christmas writi...
by kranzfr3d
Fri Dec 22, 2017 12:25 pm
Forum: Configuration
Topic: Using Letsencrypt certificate
Replies: 21
Views: 2345

Re: Using Letsencrypt certificate

[EDIT] This post is obsolete, please go here to view the "How-To" Hi, wonderful, I had a break through. Your openssl-commands got me on the right track. I played a bit with the certs whether the apache came up or not. The fullchain has to be built up this way: -----BEGIN PRIVATE KEY----- p...
by kranzfr3d
Thu Dec 21, 2017 11:20 pm
Forum: Configuration
Topic: Using Letsencrypt certificate
Replies: 21
Views: 2345

Re: Using Letsencrypt certificate

[EDIT] This post is obsolete, please go here to view the "How-To" Hi, you're right again!! Here we go, its ./exim_stage1/mainlog: 2017-12-21 22:55:54 no host name found for IP address my.ip.adr.ess 2017-12-21 22:55:54 TLS error on connection from (openssl.client.net) [my.ip.adr.ess] (SSL_C...
by kranzfr3d
Thu Dec 21, 2017 10:31 pm
Forum: Configuration
Topic: Using Letsencrypt certificate
Replies: 21
Views: 2345

Re: Using Letsencrypt certificate

[EDIT] This post is obsolete, please go here to view the "How-To" Hi, ok, something doesn't work :( if i'm connecting to mailcleaner: OpenSSL> s_client -connect mailcleaner.my.externaldomain:25 -starttls smtp CONNECTED(00000220) 5184:error:140770FC:SSL routines:SSL23_GET_SERVER_HELLO:unkno...
by kranzfr3d
Thu Dec 21, 2017 9:44 am
Forum: Configuration
Topic: Using Letsencrypt certificate
Replies: 21
Views: 2345

Re: Using Letsencrypt certificate

[EDIT] This post is obsolete, please go here to view the "How-To" hi madhopsman, wonderful, thank you for your detailed explanation! that's exactly what I needed - I ignored the apache configuration. We're getting closer, I've a very good feeling :mrgreen: [EDIT] I got it now for apache - ...
by kranzfr3d
Wed Dec 20, 2017 9:30 pm
Forum: Configuration
Topic: Using Letsencrypt certificate
Replies: 21
Views: 2345

Re: Using Letsencrypt certificate

Hi, I must have searched in wrong folder - the files are stored in "/usr/mailcleaner/etc/exim". Sorry. But it doesn't work. I found the variables "tls_certificate" and "tls_privatekey" in files "exim_stage1.conf_template", exim_stage2.conf_template and exim_st...
by kranzfr3d
Tue Dec 19, 2017 12:58 pm
Forum: Configuration
Topic: Using Letsencrypt certificate
Replies: 21
Views: 2345

Re: Using Letsencrypt certificate

mailcleaner.conf_template under apache/sites) tls_certificate = /path/to/certificate pem tls_privatekey = /path/to/private key in the following files located under /usr/mailcleaner/etc/exim: exim_stage1.conf_template exim_stage2.conf_template exim_stage4.conf_template Hello madhopsman, hello everyo...
by kranzfr3d
Fri Dec 01, 2017 2:26 pm
Forum: Configuration
Topic: How to integrate MC in exchange?
Replies: 6
Views: 414

Re: How to integrate MC in exchange?

Hello,

I've one public adress.


gr33tz
by kranzfr3d
Tue Nov 21, 2017 2:17 pm
Forum: Configuration
Topic: How to integrate MC in exchange?
Replies: 6
Views: 414

Re: How to integrate MC in exchange?

Hello nightbird, thanks for your great answer. I cannot explain me to you, that's why I painted you something see attachment of this post :D Is this the right configuration? My new questions: Which Ports do I forward to MC? I have not found them to configure into webportal :cry: How can I configure ...
by kranzfr3d
Sun Nov 19, 2017 8:56 pm
Forum: Configuration
Topic: How to integrate MC in exchange?
Replies: 6
Views: 414

How to integrate MC in exchange?

Hi, I'm new to MC, so I have a very basic setup behind me. I have a couple of MS Server 2016 with AD and an exchange 2016. All VMs are running on an ESXI 6.5. The MC is set up with my maildomain (address verfication and users authentification works) and I hit a checkbox here and there. But my main q...
by kranzfr3d
Sun Nov 19, 2017 7:20 pm
Forum: Installation
Topic: MailCleaner 2017 "Jessie" Final on ESXi6
Replies: 10
Views: 1018

Re: MailCleaner 2017 "Jessie" Final on ESXi6

Hi, I'm new to MC. Didn't know that OVA is experimental. I have a brandnew ESXI 6.5 with latest patchlevel. The OVA deployed without any issues. What I did: - New OVA-Rollout After the Shell configuration and before logging the first time into Webbrowser i did the following into shell: - /usr/mailcl...

Go to advanced search