Search found 20 matches

by ljr0
Thu Oct 26, 2017 3:30 am
Forum: Updates
Topic: Latest sanesecurity updates
Replies: 1
Views: 1136

Latest sanesecurity updates

I've noticed that the signature database maintenance has now passed to extremeshok. Has anyone installed this in 2014.10? Anything I should watch for as I install this?

Thanks
by ljr0
Thu Oct 26, 2017 3:21 am
Forum: Updates
Topic: [SOLVED] Can't install curl in the 2014/10 version
Replies: 3
Views: 1408

[SOLVED] Can't install curl in the 2014/10 version

Ok. I found a way to get curl installed. It was driving me batty because I couldn't load any of the clamspam databases or use sanesecurity among other things. I found the correct version of curl on https://www.howtoinstall.co/en/debian/squeeze/curl And then downloaded that version from the maintaine...
by ljr0
Thu Jun 22, 2017 11:47 pm
Forum: Questions
Topic: Setting DKIM signing via Mailcleaner API?
Replies: 3
Views: 1631

Re: Setting DKIM signing via Mailcleaner API?

Which version? I'm using DKIM on mine 201410 with no problems.
by ljr0
Thu Jun 22, 2017 10:05 pm
Forum: Updates
Topic: [SOLVED] Can't install curl in the 2014/10 version
Replies: 3
Views: 1408

Re: Can't install curl in the 2014/10 version

I'm using public droplets which don't allow for the KVM so far provided. I can use the ISO, but from comments I've read so far, this isn't going to happen for a while. In the meantime, my clients are getting porn. Rather frustrating.
by ljr0
Thu Jun 22, 2017 12:47 am
Forum: Updates
Topic: [SOLVED] Can't install curl in the 2014/10 version
Replies: 3
Views: 1408

[SOLVED] Can't install curl in the 2014/10 version

From what I can tell, squeeze-lts stopped support mid 2016. I not there's an update available to run a new mailcleaner version, but it's in beta and I had to build a new mailcleaner server, but I can't get curl installed. I believe I have to update sources.list, but I'm concerned that if I do, I'll ...
by ljr0
Tue Jun 28, 2016 9:37 pm
Forum: Installation
Topic: Source Install?
Replies: 7
Views: 7822

Re: Source Install?

It would really be great if there were some updates. Squeeze is impossible to maintain. I can't install any utilities. I hope the new patch (which actually sounds like a new release, not an patch) includes fail2ban. I would love to discourage the brute force password guessing.
by ljr0
Wed Apr 29, 2015 6:18 am
Forum: Configuration
Topic: is_spamsh correctly ID's email as spam but spamD doesn't
Replies: 10
Views: 4066

[SOLVED]is_spamsh correctly ID's email as spam but spamD doe

Ok. I found the problem. My DNS servers only allow certain hosts to do recursive look ups and while I was using my own DNS servers to prevent being locked out because of too many queries, apparently, I wasn't paying too much attention when I added these MX servers to the ACL. My slave MX wasn't allo...
by ljr0
Thu Apr 09, 2015 9:20 pm
Forum: Configuration
Topic: is_spamsh correctly ID's email as spam but spamD doesn't
Replies: 10
Views: 4066

Re: is_spamsh correctly ID's email as spam but spamD doesn't

I'm aware of this issue. I use my own DNS servers and not public ones. I think I mentioned that I ran spamd in debug mode and I would have seen the DNS requests being rejected, so that's not the problem. Apparently, the new child processes can't always find the correct spamassassin database as I am ...
by ljr0
Thu Apr 02, 2015 5:45 am
Forum: Configuration
Topic: is_spamsh correctly ID's email as spam but spamD doesn't
Replies: 10
Views: 4066

Re: is_spamsh correctly ID's email as spam but spamD doesn't

The other problem I noticed is the failures always seem to happen more often on child processes greater than 1. see below: Wed Apr 1 18:59:30 2015 [6541] dbg: prefork: child 6549: entering state 2 Wed Apr 1 18:59:30 2015 [6541] dbg: prefork: new lowest idle kid: 22116 Wed Apr 1 18:59:30 2015 [6549] ...
by ljr0
Thu Apr 02, 2015 5:37 am
Forum: Configuration
Topic: is_spamsh correctly ID's email as spam but spamD doesn't
Replies: 10
Views: 4066

Re: is_spamsh correctly ID's email as spam but spamD doesn't

Another thing I noticed. Almost all of the blacklist abort not quite making the time out limit. They all say, "deadline shrunk" and start aborting at around 15 seconds. One of the problems with this particular email is it has a list of about 20 legitimate domains which have nothing to do w...
by ljr0
Thu Apr 02, 2015 5:15 am
Forum: Configuration
Topic: is_spamsh correctly ID's email as spam but spamD doesn't
Replies: 10
Views: 4066

Re: is_spamsh correctly ID's email as spam but spamD doesn't

I found where to change the log mode to debug. The spam.conf file (actually the template) located in /usr/mailcleaner/etc/mailscanner. Set debug=yes. This will create very very large log files. I also noticed a lot of these in the debug mode: dbg: prefork: sysread(8) not ready, wait max 300.0 secs I...
by ljr0
Mon Mar 23, 2015 5:16 pm
Forum: Configuration
Topic: is_spamsh correctly ID's email as spam but spamD doesn't
Replies: 10
Views: 4066

Re: is_spamsh correctly ID's email as spam but spamD doesn't

I can't tell when the problem is happening. I test one that came in within minutes and is_spam works just fine. I'm using the same DNS servers on my main as I am on my slave. My main has no problems at all. But the problem gets worse, Now my spamassassin bayes scoring is coming up different between ...
by ljr0
Fri Feb 20, 2015 9:08 pm
Forum: Configuration
Topic: is_spamsh correctly ID's email as spam but spamD doesn't
Replies: 10
Views: 4066

Re: is_spamsh correctly ID's email as spam but spamD doesn't

Ok. I'm right on top of it on this check. There are no rbl problems and I did mess up the training, so now brain stuff is shown as BAYES_00. All the stuff that does show in the header of the email has the same scores as is_spam.sh. Great. But I'm missing the PYZOR_check, RAZOR2 ranges, but RAZOR2 ch...
by ljr0
Fri Feb 20, 2015 11:35 am
Forum: Configuration
Topic: is_spamsh correctly ID's email as spam but spamD doesn't
Replies: 10
Views: 4066

Re: is_spamsh correctly ID's email as spam but spamD doesn't

To add more info to this issue, I'm running mailcleaner in a cluster. The slave server seems to be the only one that's letting the spam through. I looked at the warning.logs and found that arbitrarily I'll get a sudden list of RBLs that are timing out. This lasts for about 4 hours and then goes away...
by ljr0
Fri Feb 13, 2015 11:41 pm
Forum: Configuration
Topic: spam.assassin.prefs.conf_template not being read?
Replies: 5
Views: 2276

Re: spam.assassin.prefs.conf_template not being read?

You have a file overriding the setting in spam.assassin.prefs.conf_template You might want to also check if the template settings are actually in spam.assassin.prefs.conf in the same directory. The template creates that file when spamassassin is restarted. That conf file just has some basics that ca...

Go to advanced search